





























































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="3540243" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=11f132ab8fc200573e09be8c5ede3aca" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=11f132ab8fc200573e09be8c5ede3aca" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=11f132ab8fc200573e09be8c5ede3aca" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=11f132ab8fc200573e09be8c5ede3aca" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Inlander RSS: Whole Site" href="http://www.inlander.com/spokane/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Inlander RSS: Blog Section" href="http://www.inlander.com/spokane/Rss.xml?oid=2124745" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Inlander RSS: Bloglander" href="http://www.inlander.com/spokane/Rss.xml?oid=2145962" />
      
        <link rel="alternate" type="application/rss+xml" title="Inlander RSS: Bloglander: " href="http://www.inlander.com/spokane/Rss.xml?category=2145962&amp;topic=oid%3A2124730" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Inlander RSS: Comments on Bloglander" href="http://www.inlander.com/spokane/Rss.xml?id=comments&amp;oid=2145962" />
      
        <link rel="alternate" type="application/rss+xml" title="Inlander RSS: Comments on Bloglander: " href="http://www.inlander.com/spokane/Rss.xml?category=2145962&amp;id=comments&amp;topic=oid%3A2124730" />
      
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=9424ab09a7"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=9424ab09a7"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.inlander.com\/spokane\/Profile", "http:\/\/posting.inlander.com\/spokane\/MyProfile");
  </script>
  
  
  
  
  
  

    
  

  
  <!-- Begin Google Web Fonts API Calls -->
<link href='http://fonts.googleapis.com/css?family=Lato:300,400,700|PT+Sans:400,700|Istok+Web|Oswald:300|PT+Sans+Narrow:700|PT+Serif:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Web Fonts API Calls -->


<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>


  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest&#39;s 2017 summer concert lineup &mdash; see it here | Bloglander" />
  <meta name="description" content="From classic rock to country legends to hip-hop heavyweights, there&#39;s a little something for all tastes at this year&#39;s summer concert series at Northern Quest..." />
  <meta name="keywords" content="Music, Music" />
  <title>Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest's 2017 summer concert lineup — see it here | Bloglander</title>

  
  
  
    <meta name="author" content="Dan Nailen">
  

  
  
  <meta name="news_keywords" content="music, music" />

  
  
    
  
  
    <link rel="image_src" href="https://media2.fdncms.com/inlander/imager/u/slideshow/3540683/alice-cooper-israel.jpg" />
    <meta name="thumbnail" content="https://media2.fdncms.com/inlander/imager/u/slideshow/3540683/alice-cooper-israel.jpg" />
  

  
    
      <link rel="canonical" href="http://www.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="http://www.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="http://www.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here" />
    
  

  
    <meta property="fb:app_id" content="154093878105249" />
  

  
  <meta property="og:site_name" content="Inlander" />
  <meta property="og:title" content="Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest&#39;s 2017 summer concert lineup &mdash; see it here" />
 
  
    <meta property="og:image" content="https://media2.fdncms.com/inlander/imager/u/slideshow/3540683/alice-cooper-israel.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="660" />
      <meta property="og:image:height" content="495" />
    
  

  
  
    <meta property="og:description" content="From classic rock to country legends to hip-hop heavyweights, there&#39;s a little something for all tastes at this year&#39;s summer concert series at Northern Quest..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">3540243</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170328141745</Attribute>
        <Attribute name="creationdate">20170328130141</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20170328135100</Attribute>
            <Attribute name="releasedate">20170328</Attribute>
            <Attribute name="releaseepoch">1490734260</Attribute>
            <Attribute name="title">Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest&#39;s 2017 summer concert lineup &#x2014; see it here</Attribute>
            <Attribute name="author">2349169</Attribute>
            <Attribute name="authorname">Dan Nailen</Attribute>
            <Attribute name="authorsortname">Nailen, Dan</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.inlander.com\/Bloglander\/archives\/2017\/03\/28\/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here"
          },
          "headline": "Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest's 2017 summer concert lineup — see it here",
          
            "description": "From classic rock to country legends to hip-hop heavyweights, there's a little something for all tastes at this year's summer concert series at Northern Quest Resort &amp; Casino. Here's a breakdown of all the summer has to offer (although the resort could always add some shows at a later date):",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/inlander\/imager\/u\/original\/3540683\/alice-cooper-israel.jpg",
              "width": 948,
              "height": 711,
              "@type": "ImageObject"
            },
          
          "datePublished": "2017-03-28T13:51:00",
          "dateModified": "2017-03-28T14:17:45",
          
            "author": {
              "name": "Dan Nailen",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Inlander",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.inlander.com\/imager\/b\/google-amp-logo\/808579\/c731\/inlanderFacebook.png",
                "width": 200,
                "height": 200,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/inlander/imager/u/slideshow/3540683/alice-cooper-israel.jpg">

    
    

    
      <meta name="twitter:creator" content="@dannailen">
    

    <meta name="twitter:site" content="">
    <meta name="twitter:title" content="Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest&#39;s 2017 summer concert lineup &mdash; see it here">
    <meta name="twitter:description" content="From classic rock to country legends to hip-hop heavyweights, there&#39;s a little something for all tastes at this year&#39;s summer concert series at Northern Quest...">
  
</head>





  <body id="Post" class="blog Bloglander BlogPost Iapetus10Zone">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="http://m.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<div id="Ad728x90Top" class="GlobalHeader BlogPost Ad">
  <!-- /2606185/in_blogs_a_leader -->
          <div id="div-gpt-ad-in_blogs_a_leader" style="" data-slot="/2606185/in_blogs_a_leader" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_a_leader');
                });
            </script>
          </div>
</div><!-- #Ad728x90Top -->
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        









<div id="LogoSearchLogin" class="SpanningFeature BlogPost ">
  <div class="loginSearch">
  

    
    
        

        

        
        <div class="search-wrap">
          <div class="search-link dropdown-link">
            <form class="search-form" id="searchbox_017793458706336421686:cnpz1lnlloq" action="http://www.inlander.com/spokane/Search">
              <input type="hidden" name="cx" value="017793458706336421686:cnpz1lnlloq" />
              <input type="hidden" name="cof" value="FORID:9" />
              <div class="searchElements">
                <input id="search-input" class="searchUpDown" autocomplete="off" type="text"  name="q" size="25" placeholder="SEARCH OUR SITE" />
                <input type="submit" name="sa" value="GO" />
              </div>
              
              <ul id="search-dropdown" class="search-dropdown" style="display:none;">
                <li class="search-option"><a class="search-all" href="http://www.inlander.com/spokane/Search">All</a></li>
                <li class="search-option"><a href="http://www.inlander.com/spokane/ArticleArchives">in Articles &amp; Posts</a></li>
                <li class="search-option"><a href="http://www.inlander.com/spokane/SlideshowArchives">in Slideshows</a></li>
                <li class="search-option"><a href="http://www.inlander.com/spokane/EventSearch">in Events</a></li>
                <li class="search-option"><a href="http://www.inlander.com/spokane/LocationSearch">in Locations</a></li>
              </ul>
            </form>
          </div>
        </div>

        <script>
        // 
        (function(){
          var searchFormSelector = '#LogoSearchLogin form.search-form';
          var searchInputSelector = '#LogoSearchLogin input#search-input';
          var searchDropdownSelector = '#LogoSearchLogin ul#search-dropdown';
          var searchOptionLinkSelector = '#LogoSearchLogin li.search-option a';
          var easeage = 'easeInOutCirc';
          focusInput = function(e){
            console.log(searchInputSelector);
            jQuery(searchInputSelector).off('focus', focusInput);
            jQuery(document).on('click', blurInput);
            jQuery(searchInputSelector).removeClass("searchUpDown");
            jQuery(searchDropdownSelector).slideDown('fast',easeage);
          }

          blurInput = function(e){
            // 
            if( jQuery(e.target).closest(searchFormSelector+', '+searchOptionLinkSelector).length === 0 ) {
              jQuery(document).off('click', blurInput);
              jQuery(searchInputSelector).on('focus', focusInput);
              jQuery(searchInputSelector).addClass("searchUpDown");
              jQuery(searchDropdownSelector).slideUp('fast',easeage);
            }
          }

          var canProceed = function(obj, searchAllOption){
            var emptyKeyword = jQuery(searchInputSelector).val().trim().length === 0;
            // Don't proceed without a keyword on the search-all option
            if(emptyKeyword && searchAllOption){
              return false;
            }
            return true;
          }

          enterKeywordMessage = function (){
            jQuery(searchInputSelector).attr('placeholder',"Enter a keyword.");
            window.setTimeout(function(){
              jQuery(searchInputSelector).attr('placeholder',"SEARCH OUR SITE");
            },1000);
          }

          jQuery(searchInputSelector).on('focus',focusInput);

          // 
          jQuery(searchFormSelector).submit(function(e){
            if(canProceed(e.target, true)){
              console.log('form submitted proceed');
            }else{
              e.preventDefault();
              console.log('form submitted can\'t proceed');
              enterKeywordMessage();
            }
          });

          // 
          jQuery(searchOptionLinkSelector).on('click', function(e){
            e.preventDefault();
            if(canProceed(e.target, jQuery(e.target).hasClass('search-all'))){
              console.log('link clicked proceed');
              if(jQuery(e.target).hasClass('search-all')){
                jQuery(searchFormSelector).submit();
              } else {
                var newLocation = jQuery(e.target).attr('href') || "";
                var catVal = jQuery(e.target).attr('data-category');
                var catParam = catVal != undefined ? "&category="+catVal : "";
                window.location = newLocation 
                                + "?keywords=" + jQuery(searchInputSelector).val() 
                                + "&submit=Search" 
                                + catParam;
              }
            }else{
              console.log('link clicked can"t proceed');
              enterKeywordMessage();
            }
          });

        })();
        </script>

  


  
  
  
  
    
    <ul data-view="loggedin" style="display:none">
      <li><strong data-label="username">Username</strong> / </li>
      <li><a href="http://posting.inlander.com/spokane/MyProfile">View Profile</a> / </li>
      <li><a href="http://posting.inlander.com/spokane/Profile/MySettings">Edit Profile</a> / </li>
      <li><a href="http://www.inlander.com/spokane/Logout">Log Out</a></li>
    </ul>

    <ul data-view="loggedout" style="display:none">
      <li><a href="#LogIn">Log in</a></li>
      <li><a href="#CreateAccount">Sign Up</a></li>
    </ul>
  
   </div>
  
  
  
         

     <div id="header-logo">
     <p id="headerSlogan">
     America's best read urban weekly | <a href="http://www.inlander.com/spokane/WhoWeAre/Page">Learn More &raquo;</a>
     </p>
     
       <div id="logo"><a href="http://www.inlander.com/" title="Inlander">Inlander</a></div>
     </div>
  
  
</div>



  <script>
    new Foundation.LoginRequiredComponent("LogoSearchLogin");
  </script>



















  <div id="NavigationHorizontal" class="SpanningFeature BlogPost ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_NewsComment">
          <a href="http://www.inlander.com/spokane/news-and-comment/Section?oid=2124740"  class="subnav_link" id="SNAVL_NewsComment">News &amp; Comment</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_CultureFood">
          <a href="http://www.inlander.com/spokane/culture-and-food/Section?oid=2124741"  class="subnav_link" id="SNAVL_CultureFood">Culture &amp; Food</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_MusicFilm">
          <a href="http://www.inlander.com/spokane/music-and-film/Section?oid=2124742"  class="subnav_link" id="SNAVL_MusicFilm">Music &amp; Film</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_InHealth">
          <a href="http://www.inlander.com/spokane/in-health/Section?oid=2185553"  class="subnav_link" id="SNAVL_InHealth">InHealth</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_LocalBusiness">
          <a href="#"  class="subnav_link" id="SNAVL_LocalBusiness">Promotions</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News &amp; Comment</h3>
            <ul class="subnav_content" id="SNAV_NewsComment" style="display:none;">
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/news/Category?oid=2124763"  title="">News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/comment/Category?oid=2124753"  title="">Comment</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/IssueArchives?issue=2991167"  title="">GZ Quarterly</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/green-zone/Category?oid=2318349"  title="">Green Zone</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/ArticleArchives?section=2124740"  title="">Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Culture &amp; Food</h3>
            <ul class="subnav_content" id="SNAV_CultureFood" style="display:none;">
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/arts-and-culture/Category?oid=2124747"  title="">Arts &amp; Culture</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/food-and-drink/Category?oid=2124758"  title="">Food &amp; Drink</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/LocationSearch?locationSection=2151205"  title="">Restaurants</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/LocationSearch?feature=Happy%20Hour&Day=Today&sortType=range"  title="">Happy Hours</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/IssueArchives?issue=2873250"  title="">Annual Manual</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/i-saw-you/Category?oid=2436355"  title="">Read &quot;I Saw You&quot;</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/ISawYouformSubmission/Page"  title="">Submit &quot;I Saw You&quot;</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/ArticleArchives?section=2124741"  title="">Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music &amp; Film</h3>
            <ul class="subnav_content" id="SNAV_MusicFilm" style="display:none;">
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/music/Category?oid=2124762"  title="">Music</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/EventSearch?eventSection=2163369"  title="">Live Music Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://volume.inlander.com/"  title="">Volume Music Festival</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/film/Category?oid=2124757"  title="">Film</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/MovieTimes"  title="">Movie Times</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/ArticleArchives?section=2124742"  title="">Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse InHealth</h3>
            <ul class="subnav_content" id="SNAV_InHealth" style="display:none;">
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/inhealth/Section?oid=2185553"  title="">InHealth</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://www.inlander.com/spokane/IssueArchives?special=InHealth"  title="">InHealth Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Promotions</h3>
            <ul class="subnav_content" id="SNAV_LocalBusiness" style="display:none;">
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/freestuff"  title="">Contests</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://inlanderrestaurantweek.com/"  title="">Inlander Restaurant Week</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://snowlanderexpo.com/powderkeg/"  title="">PowderKeg Inlander Brew Festival</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://snowlanderexpo.com"  title="">Snowlander Expo</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.inlander.com/spokane/ArticleArchives?category=2439834"  title="">Suds and Cinema</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://volume.inlander.com/"  title="">Volume Inlander Music Festival</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://in.inlander.com/game/" target="_blank" title="">Inlander Dude</a>
          </li>
          
            </ul>
          
        

        

        
        
        
          <script type="text/javascript"><!--
            Event.observe(document, "dom:loaded", function () {
              var panellinks = $$('.subnav_link');
              panellinks.each(function(fl) {
                var panel_id = 'SNAV_'+fl.id.split('_')[1];
                var link_w = fl.getWidth();
                new FloatingPanel(fl,panel_id,{
                  rightOffset:'-' + (link_w + 0),
                  topOffset:'24',
                  effects: 'off',
                  closeDelay:'0',
                  allowDefault: true,
                  beforeOpen: function() {
                    fl.addClassName('hover');
                    Element.up(fl).addClassName('hover');
                  },
                  beforeClose: function() {
                    fl.removeClassName('hover');
                    Element.up(fl).removeClassName('hover');
                  }
                });
              });
            });
          // --></script>
        
      
    
  </div>


  

  
  
  


<!-- End #NavigationHorizontal -->


  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost  topic_music Bloglander">
    <a href="http://www.inlander.com/blogs/Bloglander/">
    <h1 class="Bloglander">
      
        Bloglander
      
    </h1>
    </a>

    

    <p>
      
        <a href="http://www.inlander.com/spokane/Bloglander/blogs/Archives">Archives</a> |
        <a href="/spokane/Rss.xml?category=2145962">RSS</a>
      
      
    </p>
  </div>






  

  

  
  

  

  <div id="TabbedBlogTopics" class="SpanningFeature BlogPost ">
    <div class="tabs">
      <ul>
        <li><a class="first" href="http://www.inlander.com/blogs/Bloglander/">The Latest</a></li>
        

          

          <li>
            <a class="" href="http://www.inlander.com/Bloglander/archives/news/">
              News
            </a>
          </li>
        

          

          <li>
            <a class="" href="http://www.inlander.com/Bloglander/archives/arts-and-culture/">
              Arts & Culture
            </a>
          </li>
        

          

          <li>
            <a class="" href="http://www.inlander.com/Bloglander/archives/music/">
              Music
            </a>
          </li>
        

          

          <li>
            <a class="last" href="http://www.inlander.com/Bloglander/archives/inhealth/">
              InHealth
            </a>
          </li>
        
      </ul>
      <div class="clear"></div>
    </div>
  </div><!-- End TabbedBlogTopics -->














  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/28/community-colleges-of-spokane-moves-pullman-classes-to-wsu-campus" class="prev" rel="prev">&laquo;&nbsp;Community Colleges of Spokane moves&hellip;</a>
    </div>
  </div>








  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="SpanningFeature BlogPost  topicView topic_music">
    
    
    
    
    
    
      
      
        <h2 class="blogDate">Tuesday, March 28, 2017</h2>
      
    
      
      <div class="blogPost bloglander topic-music">
    
    
      <div class="postCategories">
        <span class="postCategory CategoryBloglander">
          <a href="http://www.inlander.com/Bloglander/archives/music/" class="topic-music">Music</a>
        </span>
      </div>
    
    <h3 class="postTitle" id="a3540243">
      
      
      
      
      
      
        Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest's 2017 summer concert lineup — see it here
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        Posted
        
          
          By <a href="http://www.inlander.com/spokane/ArticleArchives?author=2349169" rel="author">Dan Nailen</a>
        
        
          
            on <span class="postTime">Tue, Mar 28, 2017</span> at <span class="postTime"> 1:51 PM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      
      
       
      
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/inlander/imager/u/original/3540683/alice-cooper-israel.jpg" class="zoomable" rel="contentImg_gal-3540243" title="Alice Cooper kicks off this summer&#39;s shows at Northern Quest.">                  <img src="https://media2.fdncms.com/inlander/imager/u/blog/3540683/alice-cooper-israel.jpg?cb=1490733897" width="660" height="495" alt="Alice Cooper kicks off this summer&#39;s shows at Northern Quest." />                </a>                                                                                                           <ul style="width:660px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                <li class="imageCaption">                      Alice Cooper kicks off this summer's shows at Northern Quest.                    </li>                                                                                                </ul>                                                       </div><br>
 From classic rock to country legends to hip-hop heavyweights, there's a little something for all tastes at this year's <a href="https://northernquest.com/outdoor-summer-concerts" target="_blank">summer concert series</a> at Northern Quest Resort &amp; Casino. <br>
 <br>
 Here's a breakdown of all the summer has to offer (although the resort could always add some shows at a later date):<br>
 <br>
 <b><a href="http://www.alicecooper.com/" target="_blank">ALICE COOPER</a>, June 18, $45/$55/$65, on sale April 1.</b> The shock-rock legend puts on a great live show, and you might be able to catch him golfing somewhere earlier in the day if you can recognize him without his makeup. <br>
 <br>
 <b><a href="http://www.redrocker.com/discography/at-your-service" target="_blank">SAMMY HAGAR AND THE CIRCLE</a>, June 30, $65/$75/$85, on sale April 1.</b> The longtime lead singer for Van Halen and solo artist brings a band that includes former Van Halen bassist Michael Anthony, drummer Jason (son of John) Bonham and guitarist Vic Johnson to delve into all eras of Hagar's career, plus a few Zeppelin covers. <br>
 <br>
 <b><a href="http://www.sublimewithrome.com/" target="_blank">SUBLIME WITH ROME</a> AND <a href="http://offspring.com/" target="_blank">THE OFFSPRING</a>, July 6, $44/$65/$85, on sale April 1.</b> Two of the biggest bands of the '90s on tour together and delivering hits like "What I Got" and "Keep 'Em Separated." <br>
 <br>
 <b><a href="http://donny.com/" target="_blank">DONNY</a> AND <a href="https://www.facebook.com/marieosmond/" target="_blank">MARIE</a>, July 16, $55/$65/$85, on sale April 1.</b> They've performed together on Las Vegas and toured separately for years, but this show is the rare treat when the two '70s icons hit the road together for a show. <br>

<a name="more"></a>

 <br>
 <b><a href="http://www.officialflo.com/" target="_blank">FLO RIDA</a> AND SKY, July 20, $55/$65/$75, on sale April 1.</b> The mega-selling Flo Rida has a set full of Top 10 hits and a new album on the way, while Sky will delve into the LMFAO catalog in support. <br>
 <br>
 <b><a href="http://www.tobykeith.com/" target="_blank">TOBY KEITH</a>, Aug. 3, $75/$86/$105, on sale April 8.</b> The country superstar behind "Red Solo Cup" and "Beer for My Horses" returns to Spokane for a hot August night. <br>
  <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/inlander/imager/u/original/3540682/willie-nelson.jpg" class="zoomable" rel="contentImg_gal-3540243" title="Wille Nelson">                  <img src="https://media1.fdncms.com/inlander/imager/u/blog/3540682/willie-nelson.jpg?cb=1490733909" width="250" height="141" alt="Wille Nelson" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                <li class="imageCaption">                      Wille Nelson                    </li>                                                                                                </ul>                                                       </div><a href="http://www.willienelson.com/" target="_blank"><br>
<b> WILLIE NELSON AND FAMILY</b></a><b> WITH <a href="http://www.kaceymusgraves.com/" target="_blank">KACEY MUSGRAVES</a>, Aug. 8, $55/$65/$85, on sale April 8.</b> Two generations of traditional country sounds in one big show. Willie is back on the road after a health scare, supported by his stellar Family band, while Musgraves is one of the brightest young stars in country. <br>
 <br>
 <b><a href="http://www.bozscaggs.com/" target="_blank">BOZ SCAGGS </a>AND <a href="http://www.michaelmcdonald.com/" target="_blank">MICHAEL MCDONALD</a>, Aug. 11, $45/$55/$75, on sale April 8. </b>These '70s icons regularly headline their own shows. With both on board in one night, expect non-stop hits. <br>
 <br>
 <b><a href="http://www.hankjr.com/" target="_blank">HANK WILLIAMS, JR.</a> AND <a href="http://www.thecadillacthree.com/" target="_blank">THE CADILLAC THREE</a>, Sept. 15, $65/$75/$85, on sale April 8.</b> The ornery Williams is ready to get rowdy at Northern Quest once again after visiting two summers ago. <br>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
        
        















  
  
  

  

  

  
  


        <ul class="horizontalShareTools">
          <li class="l0 first">
            <div style="overflow:hidden;"><fb:like href="http://www.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div></li> <li class="l0"><a href="http://twitter.com/share?url=http%3A//www.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here&text=Willie%2C%20Flo%20Rida%2C%20Sammy%20Hagar%20and%20Alice%20Cooper%20among%20Northern%20Quest%27s%202017%20summer%20concert%20lineup%20%E2%80%94%20see%20it%20here" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0">


  

  

  

  <a href="http://pinterest.com/pin/create/button/?description=Willie%2C%20Flo%20Rida%2C%20Sammy%20Hagar%20and%20Alice%20Cooper%20among%20Northern%20Quest%27s%202017%20summer%20concert%20lineup%20%E2%80%94%20see%20it%20here&amp;media=https%3A%2F%2Fmedia2.fdncms.com%2Finlander%2Fimager%2Fu%2Fslideshow%2F3540683%2Falice-cooper-israel.jpg&amp;url=http%3A%2F%2Fwww.inlander.com%2FBloglander%2Farchives%2F2017%2F03%2F28%2Fwillie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("http://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</li> <li class="l0">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="http://posting.inlander.com/spokane/Profile/MyFavorites?add=3540243">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="3540243" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</li> <li class="l0">

<a class="emailAction" title="Email" href="http://posting.inlander.com/spokane/Tools/EmailFriend?oid=3540243" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</li> <li class="l0">




  <div class="addthis_toolbox addthis_default_style"><a href="http://www.addthis.com/bookmark.php?v=300&pubid=xa-5196a60e5cd22468" addthis:url="http://www.inlander.com/Bloglander/archives/2017/03/28/willie-flo-rida-sammy-hagar-and-alice-cooper-among-northern-quests-2017-summer-concert-lineup-see-it-here" addthis:title="Willie, Flo Rida, Sammy Hagar and Alice Cooper among Northern Quest's 2017 summer concert lineup — see it here" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-5196a60e5cd22468", true);
  </script>


          </li>
        </ul>
      
    

    

    
      
      <p class="tags">
        Tags: <a href="http://www.inlander.com/spokane/ArticleArchives?tag=Music" rel="tag">Music</a>, <a href="http://www.inlander.com/spokane/ArticleArchives?contentFeature=2130750" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>





















  



    
    
    
    


















  

  

  
  

  

  



























  
  
      <div id="RecentByTag" class="SpanningFeature BlogPost ">
        <h3 class="latestbloglander">
          <span class="headingText">
          
            Speaking of Music
          
          </span>      
        </h3>
        
        <ul class="moduleList">
    
    
    
          

    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/spokane-arena-adds-matchbox-20-counting-crows-piano-guys-to-upcoming-schedule">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/3526503/matchbox_20.jpg" alt="Spokane Arena adds Matchbox 20, Counting Crows, Piano Guys to upcoming schedule" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/spokane-arena-adds-matchbox-20-counting-crows-piano-guys-to-upcoming-schedule">Spokane Arena adds Matchbox 20, Counting Crows, Piano Guys to upcoming schedule</a>
    </h4>
    <div class="date">Mar 27, 2017</div>
  </li>

    
  
    
    
          

    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/concert-review-social-distortions-reliable-rock-fills-the-knit">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/3517858/socialdbest.jpg" alt="CONCERT REVIEW: Social Distortion&#39;s reliable rock fills the Knit" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/concert-review-social-distortions-reliable-rock-fills-the-knit">CONCERT REVIEW: Social Distortion's reliable rock fills the Knit</a>
    </h4>
    <div class="date">Mar 27, 2017</div>
  </li>

    
  
    
    
          

    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/23/tonights-strkfr-show-is-canceled">
        <img src="https://media1.fdncms.com/inlander/imager/u/bigsquare/3479025/strfkr.jpg" alt="Tonight&#39;s STRFKR show is canceled" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/23/tonights-strkfr-show-is-canceled">Tonight's STRFKR show is canceled</a>
    </h4>
    <div class="date">Mar 23, 2017</div>
  </li>

    
  
        
          <li class="l0 storyItem more">
            <a href="http://www.inlander.com/spokane/ArticleArchives?tag=Music" class="more">More &raquo;</a>
          </li>
        
        </ul>
      </div>
    
  









  
  
      <div id="LatestInCategory" class="SpanningFeature BlogPost ">
        <h3 class="latestbloglander"><span class="headingText">Latest in Bloglander</span></h3>
        <ul class="moduleList">
    
    
    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/28/community-colleges-of-spokane-moves-pullman-classes-to-wsu-campus">
        <img src="https://media1.fdncms.com/inlander/imager/u/bigsquare/3540678/wsu_building_sfcc_campus.jpg" alt="Community Colleges of Spokane moves Pullman classes to WSU campus" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/28/community-colleges-of-spokane-moves-pullman-classes-to-wsu-campus">Community Colleges of Spokane moves Pullman classes to WSU campus</a>
    </h4>
    <div class="date">Mar 28, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/28/idaho-farmers-double-life-spokane-construction-season-and-morning-headlines">
        <img src="https://media1.fdncms.com/inlander/imager/u/bigsquare/3537371/art15534.jpg" alt="Idaho farmer&#39;s double life, Spokane construction season, and morning headlines" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/28/idaho-farmers-double-life-spokane-construction-season-and-morning-headlines">Idaho farmer's double life, Spokane construction season, and morning headlines</a>
    </h4>
    <div class="date">Mar 28, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/lawsuit-over-torturous-euthanasia-of-cle-elum-mans-dog-could-set-new-precedent">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/3527288/lawsuit-pen-glasses.jpg" alt="Lawsuit over &#39;torturous&#39; euthanasia of Cle Elum man&#39;s dog could set new precedent" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/lawsuit-over-torturous-euthanasia-of-cle-elum-mans-dog-could-set-new-precedent">Lawsuit over 'torturous' euthanasia of Cle Elum man's dog could set new precedent</a>
    </h4>
    <div class="date">Mar 27, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/spokane-arena-adds-matchbox-20-counting-crows-piano-guys-to-upcoming-schedule">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/3526503/matchbox_20.jpg" alt="Spokane Arena adds Matchbox 20, Counting Crows, Piano Guys to upcoming schedule" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/spokane-arena-adds-matchbox-20-counting-crows-piano-guys-to-upcoming-schedule">Spokane Arena adds Matchbox 20, Counting Crows, Piano Guys to upcoming schedule</a>
    </h4>
    <div class="date">Mar 27, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/concert-review-social-distortions-reliable-rock-fills-the-knit">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/3517858/socialdbest.jpg" alt="CONCERT REVIEW: Social Distortion&#39;s reliable rock fills the Knit" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/concert-review-social-distortions-reliable-rock-fills-the-knit">CONCERT REVIEW: Social Distortion's reliable rock fills the Knit</a>
    </h4>
    <div class="date">Mar 27, 2017</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/alton-brown-heads-to-town-zags-hit-final-four-and-morning-headlines">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/3525433/gonzaga-mens-basketball-v-utah-valley-1013-2.jpg" alt="Alton Brown heads to town, Zags hit final four, and morning headlines" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/alton-brown-heads-to-town-zags-hit-final-four-and-morning-headlines">Alton Brown heads to town, Zags hit final four, and morning headlines</a>
    </h4>
    <div class="date">Mar 27, 2017</div>
  </li>
    
  
         <li class="l0 storyItem more">
           <a href="http://www.inlander.com/spokane/ArticleArchives?category=2145962" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    


<div id="Ad660x90x1" class="SpanningFeature BlogPost Ad">
  <!-- /2606185/in_blogs_j_banner -->
          <div id="div-gpt-ad-in_blogs_j_banner" style="" data-slot="/2606185/in_blogs_j_banner" data-output="asynchronous" data-width="660" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_j_banner');
                });
            </script>
          </div>
</div><!-- #Ad660x90x1 -->





  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="SpanningFeature BlogPost CommentsComponent  closed">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

          
        <hr />

        

        
          <p class="notice">Comments are closed.
            
          </p>
          

        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  









  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature BlogPost ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2015/08/24/more-drivers-test-positive-for-thc-seattle-lawyer-says-legal-limit-unconstitutional">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/2545094/dank_nugs.jpg" alt="More drivers test positive for THC; Seattle lawyer says legal limit unconstitutional" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2015/08/24/more-drivers-test-positive-for-thc-seattle-lawyer-says-legal-limit-unconstitutional">More drivers test positive for THC; Seattle lawyer says legal limit unconstitutional</a>
    </h4>
    <div class="date">Aug 24, 2015</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2015/08/27/featuring-spokane-macklemores-new-music-video-downtown">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/2548745/macklemore-downtown-cover.jpg" alt="A first look at Macklemore &amp;amp; Ryan Lewis&#39; new Spokane-shot video &quot;Downtown&quot;" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2015/08/27/featuring-spokane-macklemores-new-music-video-downtown">A first look at Macklemore &amp; Ryan Lewis' new Spokane-shot video "Downtown"</a>
    </h4>
    <div class="date">Aug 27, 2015</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      <a href="http://www.inlander.com/Bloglander/archives/2015/08/28/why-the-albertson-foundation-is-using-a-bright-yellow-deer-to-get-idaho-kids-to-college">
        <img src="https://media2.fdncms.com/inlander/imager/u/bigsquare/2549600/cnblcqiusaajsjh.jpg" alt="Why the Albertson Foundation is using a bright yellow deer to get Idaho kids to college" />
      </a>
    
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2015/08/28/why-the-albertson-foundation-is-using-a-bright-yellow-deer-to-get-idaho-kids-to-college">Why the Albertson Foundation is using a bright yellow deer to get Idaho kids to college</a>
    </h4>
    <div class="date">Aug 28, 2015</div>
  </li>
      
      
    
          </ul>
        </div>
      
               

      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        <div id="Ad300x115x1" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_b_promo -->
          <div id="div-gpt-ad-in_blogs_b_promo" style="" data-slot="/2606185/in_blogs_b_promo" data-output="asynchronous" data-width="300" data-height="115">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_b_promo');
                });
            </script>
          </div>
</div><!-- #Ad300x115x1 -->

























<div id="EventPicksChooser" class="SpanningIsland BlogPost ">

  <div class="headerBar">
    <h2><a href="http://www.inlander.com/spokane/EventSearch">Events</a> &amp; <a href="http://www.inlander.com/spokane/EventSearch?feature=Staff%20Pick">Staff Picks</a></h2></a>
  </div>

  <!-- /2606185/in_events_n_sponsor -->
          <div id="div-gpt-ad-in_events_n_sponsor" style="" data-slot="/2606185/in_events_n_sponsor" data-output="asynchronous" data-width="300" data-height="25">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_events_n_sponsor');
                });
            </script>
          </div>

  
    

    <div class="calendarDays">
      <a class="calCurrent" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=today">Today</a>
      
        | <a class="calDay" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=2017-03-29%2004%3A00%3A00">Wed</a>
      
        | <a class="calDay" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=2017-03-30%2004%3A00%3A00">Thu</a>
      
        | <a class="calDay" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=2017-03-31%2004%3A00%3A00">Fri</a>
      
        | <a class="calDay" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=2017-04-01%2004%3A00%3A00">Sat</a>
      
        | <a class="calDay" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=2017-04-02%2004%3A00%3A00">Sun</a>
      
        | <a class="calDay last" href="http://www.inlander.com/spokane/EventSearch?narrowByDate=2017-04-03%2004%3A00%3A00">Mon</a>
      
    </div>

    
    
      <div class="storyItem">
    

    

    
      <a href="http://www.inlander.com/spokane/mammoths-and-mastodons-titans-of-the-ice-age/Event?oid=3001827">
        <img src="https://media2.fdncms.com/inlander/imager/u/homesectionfeature/3001826/unnamed.jpg" alt="Mammoths &amp; Mastodons: Titans of the Ice Age" title="Mammoths &amp; Mastodons: Titans of the Ice Age" width="140" height="140" />
      </a>
     
     <h4 class="headline"><a href="http://www.inlander.com/spokane/mammoths-and-mastodons-titans-of-the-ice-age/Event?oid=3001827">Mammoths & Mastodons: Titans of the Ice Age</a>  
       <span class="smaller">@ Northwest Museum of Arts & Culture</span>
     </h4>
      <h5 class="subhead">Tuesdays-Sundays. Continues through May 7</h5>

  </div>
      

  
 
  <p class="more"><a href="http://www.inlander.com/spokane/EventSearch?narrowByDate=today">All of today's events</a> | <a href="http://www.inlander.com/spokane/EventSearch?feature=Staff%20Pick">Staff Picks</a></p>

  

  <div id=""> <!-- Tabbed Box -->  
    <div class="tabs">  
      <div class="tabCurrent tabLeft"><a href="#">Events</a></div> 
      <div class="tabBack tabCenter"><a href="#">Music</a></div> 
      <div class="tabBack tabCenter"><a href="#">Movies</a></div> 
      <div class="tabBack tabRight"><a href="#">Dining</a></div>
      <div class="tabBack tabRight"><a href="#">Locations</a></div>
    </div>
    <div class="clear"></div>

    

    <div class="eventSearchBody" >
      <form name="eventSearchForm" method="get" action="http://www.inlander.com/spokane/EventSearch">
        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2017-03-28" selected="selected">Tuesday, March 28</option>
        
      
        
        
          <option value="2017-03-29">Wednesday, March 29</option>
        
      
        
        
          <option value="2017-03-30">Thursday, March 30</option>
        
      
        
        
          <option value="2017-03-31">Friday, March 31</option>
        
      
        
        
          <option value="2017-04-01">Saturday, April  1</option>
        
      
        
        
          <option value="2017-04-02">Sunday, April  2</option>
        
      
        
        
          <option value="2017-04-03">Monday, April  3</option>
        
      
        
        
          <option value="2017-04-04">Tuesday, April  4</option>
        
      
        
        
          <option value="2017-04-05">Wednesday, April  5</option>
        
      
        
        
          <option value="2017-04-06">Thursday, April  6</option>
        
      
        
        
          <option value="2017-04-07">Friday, April  7</option>
        
      
        
        
          <option value="2017-04-08">Saturday, April  8</option>
        
      
        
        
          <option value="2017-04-09">Sunday, April  9</option>
        
      
        
        
          <option value="2017-04-10">Monday, April 10</option>
        
      
        
        
          <option value="2017-04-11">Tuesday, April 11</option>
        
      
        
        
          <option value="2017-04-12">Wednesday, April 12</option>
        
      
        
        
          <option value="2017-04-13">Thursday, April 13</option>
        
      
        
        
          <option value="2017-04-14">Friday, April 14</option>
        
      
        
        
          <option value="2017-04-15">Saturday, April 15</option>
        
      
        
        
          <option value="2017-04-16">Sunday, April 16</option>
        
      
        
        
          <option value="2017-04-17">Monday, April 17</option>
        
      
        
        
          <option value="2017-04-18">Tuesday, April 18</option>
        
      
        
        
          <option value="2017-04-19">Wednesday, April 19</option>
        
      
        
        
          <option value="2017-04-20">Thursday, April 20</option>
        
      
        
        
          <option value="2017-04-21">Friday, April 21</option>
        
      
        
        
          <option value="2017-04-22">Saturday, April 22</option>
        
      
        
        
          <option value="2017-04-23">Sunday, April 23</option>
        
      
        
        
          <option value="2017-04-24">Monday, April 24</option>
        
      
        
        
          <option value="2017-04-25">Tuesday, April 25</option>
        
      
        
        
          <option value="2017-04-26">Wednesday, April 26</option>
        
      
        
        
          <option value="2017-04-27">Thursday, April 27</option>
        
      
    
  </select>

        <select name="eventCategory">
          <option value="">-All Categories-</option>
          
            <option value="2193314" >&nbsp;&nbsp;Benefit</option>
          
            <option value="2151680" >&nbsp;&nbsp;Comedy</option>
          
            <option value="2151681" >&nbsp;&nbsp;Community</option>
          
            <option value="2151693" >&nbsp;&nbsp;Crafts</option>
          
            <option value="2151691" >&nbsp;&nbsp;Etc.</option>
          
            <option value="2343258" >&nbsp;&nbsp;Fall Arts</option>
          
            <option value="2151690" >&nbsp;&nbsp;Farmers Market</option>
          
            <option value="2151682" >&nbsp;&nbsp;Festival</option>
          
            <option value="2151683" >&nbsp;&nbsp;Film</option>
          
            <option value="2151684" >&nbsp;&nbsp;Food & Drink</option>
          
            <option value="2367143" >&nbsp;&nbsp;Health & Wellness</option>
          
            <option value="2375250" >&nbsp;&nbsp;Holiday Guide</option>
          
            <option value="2210491" >&nbsp;&nbsp;Museums</option>
          
            <option value="2151685" >&nbsp;&nbsp;Music Events & Concerts</option>
          
            <option value="2151694" >&nbsp;&nbsp;Performance Arts</option>
          
            <option value="2151686" >&nbsp;&nbsp;Sports & Outdoors</option>
          
            <option value="2306121" >&nbsp;&nbsp;Summer Guide</option>
          
            <option value="2151687" >&nbsp;&nbsp;Theater</option>
          
            <option value="2151695" >&nbsp;&nbsp;Trivia</option>
          
            <option value="2151688" >&nbsp;&nbsp;Visual Arts</option>
          
            <option value="2195464" >&nbsp;&nbsp;Volunteer Opportunities</option>
          
            <option value="2151689" >&nbsp;&nbsp;Words</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2151278" >&nbsp;&nbsp;Spokane - Downtown</option>
      
        <option value="2151280" >&nbsp;&nbsp;Spokane - South</option>
      
        <option value="2151279" >&nbsp;&nbsp;Spokane - North</option>
      
        <option value="2151282" >&nbsp;&nbsp;Spokane - West</option>
      
        <option value="2151281" >&nbsp;&nbsp;Spokane Valley</option>
      
        <option value="2151285" >&nbsp;&nbsp;Coeur d'Alene/Post Falls</option>
      
        <option value="2151286" >&nbsp;&nbsp;Sandpoint</option>
      
        <option value="2151291" >&nbsp;&nbsp;Airway Heights</option>
      
        <option value="2151284" >&nbsp;&nbsp;Cheney</option>
      
        <option value="2151287" >&nbsp;&nbsp;Moscow/Pullman</option>
      
        <option value="2151288" >&nbsp;&nbsp;Rural Eastern WA</option>
      
        <option value="2151289" >&nbsp;&nbsp;Rural Idaho</option>
      
        <option value="2151290" >&nbsp;&nbsp;Spokane - East</option>
      
        <option value="2151283" >&nbsp;&nbsp;Liberty Lake</option>
      
        <option value="2151293" >&nbsp;&nbsp;Montana</option>
      
        <option value="2151292" >&nbsp;&nbsp;Canada</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="http://posting.inlander.com/spokane/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="musicEventSearchForm" method="get" action="http://www.inlander.com/spokane/EventSearch">
        <input type="hidden" name="eventSection" value="2163369" />

        <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2017-03-28" selected="selected">Tuesday, March 28</option>
        
      
        
        
          <option value="2017-03-29">Wednesday, March 29</option>
        
      
        
        
          <option value="2017-03-30">Thursday, March 30</option>
        
      
        
        
          <option value="2017-03-31">Friday, March 31</option>
        
      
        
        
          <option value="2017-04-01">Saturday, April  1</option>
        
      
        
        
          <option value="2017-04-02">Sunday, April  2</option>
        
      
        
        
          <option value="2017-04-03">Monday, April  3</option>
        
      
        
        
          <option value="2017-04-04">Tuesday, April  4</option>
        
      
        
        
          <option value="2017-04-05">Wednesday, April  5</option>
        
      
        
        
          <option value="2017-04-06">Thursday, April  6</option>
        
      
        
        
          <option value="2017-04-07">Friday, April  7</option>
        
      
        
        
          <option value="2017-04-08">Saturday, April  8</option>
        
      
        
        
          <option value="2017-04-09">Sunday, April  9</option>
        
      
        
        
          <option value="2017-04-10">Monday, April 10</option>
        
      
        
        
          <option value="2017-04-11">Tuesday, April 11</option>
        
      
        
        
          <option value="2017-04-12">Wednesday, April 12</option>
        
      
        
        
          <option value="2017-04-13">Thursday, April 13</option>
        
      
        
        
          <option value="2017-04-14">Friday, April 14</option>
        
      
        
        
          <option value="2017-04-15">Saturday, April 15</option>
        
      
        
        
          <option value="2017-04-16">Sunday, April 16</option>
        
      
        
        
          <option value="2017-04-17">Monday, April 17</option>
        
      
        
        
          <option value="2017-04-18">Tuesday, April 18</option>
        
      
        
        
          <option value="2017-04-19">Wednesday, April 19</option>
        
      
        
        
          <option value="2017-04-20">Thursday, April 20</option>
        
      
        
        
          <option value="2017-04-21">Friday, April 21</option>
        
      
        
        
          <option value="2017-04-22">Saturday, April 22</option>
        
      
        
        
          <option value="2017-04-23">Sunday, April 23</option>
        
      
        
        
          <option value="2017-04-24">Monday, April 24</option>
        
      
        
        
          <option value="2017-04-25">Tuesday, April 25</option>
        
      
        
        
          <option value="2017-04-26">Wednesday, April 26</option>
        
      
        
        
          <option value="2017-04-27">Thursday, April 27</option>
        
      
    
  </select>
        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2151278" >&nbsp;&nbsp;Spokane - Downtown</option>
      
        <option value="2151280" >&nbsp;&nbsp;Spokane - South</option>
      
        <option value="2151279" >&nbsp;&nbsp;Spokane - North</option>
      
        <option value="2151282" >&nbsp;&nbsp;Spokane - West</option>
      
        <option value="2151281" >&nbsp;&nbsp;Spokane Valley</option>
      
        <option value="2151285" >&nbsp;&nbsp;Coeur d'Alene/Post Falls</option>
      
        <option value="2151286" >&nbsp;&nbsp;Sandpoint</option>
      
        <option value="2151291" >&nbsp;&nbsp;Airway Heights</option>
      
        <option value="2151284" >&nbsp;&nbsp;Cheney</option>
      
        <option value="2151287" >&nbsp;&nbsp;Moscow/Pullman</option>
      
        <option value="2151288" >&nbsp;&nbsp;Rural Eastern WA</option>
      
        <option value="2151289" >&nbsp;&nbsp;Rural Idaho</option>
      
        <option value="2151290" >&nbsp;&nbsp;Spokane - East</option>
      
        <option value="2151283" >&nbsp;&nbsp;Liberty Lake</option>
      
        <option value="2151293" >&nbsp;&nbsp;Montana</option>
      
        <option value="2151292" >&nbsp;&nbsp;Canada</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
      <div class="clear"></div>
      <p class="submitLink"><a href="http://posting.inlander.com/spokane/Events/AddEvent">Submit an Event</a></p>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="movietimesSearchForm" method="get" action="http://www.inlander.com/spokane/MovieTimes">
        <select name="film" onchange="submit();">
          <option value="">Select a movie</option>
          
            <option value="2995492">Beauty and the Beast</option>
          
            <option value="2995493">Beauty and the Beast 3D</option>
          
            <option value="2996557">Beauty and the Beast: An IMAX 3D Experience</option>
          
            <option value="2996567">Beauty and the Beast: The IMAX 2D Experience</option>
          
            <option value="3387393">The Belko Experiment</option>
          
            <option value="3276946">CHIPS</option>
          
            <option value="2985212">A Dog&#39;s Purpose</option>
          
            <option value="2918644">Fantastic Beasts and Where to Find Them</option>
          
            <option value="3001541">Fist Fight</option>
          
            <option value="3004250">Get Out</option>
          
            <option value="2993564">The Great Wall</option>
          
            <option value="2972606">Hidden Figures</option>
          
            <option value="2997832">John Wick: Chapter 2</option>
          
            <option value="3005232">Kong: Skull Island</option>
          
            <option value="3070215">Kong: Skull Island 3D</option>
          
            <option value="2971564">La La Land</option>
          
            <option value="3462030">The Last Word</option>
          
            <option value="2990959">The LEGO Batman Movie</option>
          
            <option value="3320183">Life</option>
          
            <option value="3005235">Logan</option>
          
            <option value="2997854">MindGamers: One Thousand Minds Connected LIVE</option>
          
            <option value="2942518">Moana</option>
          
            <option value="2980558">Monster Trucks</option>
          
            <option value="2962825">Passengers</option>
          
            <option value="3144103">The Red Turtle</option>
          
            <option value="3102220">Rock Dog</option>
          
            <option value="2957079">Rogue One: A Star Wars Story</option>
          
            <option value="3276940">Saban&#39;s Power Rangers</option>
          
            <option value="3396186">The Sense of an Ending</option>
          
            <option value="2986764">The Shack</option>
          
            <option value="2962817">Sing</option>
          
            <option value="2984248">Split</option>
          
            <option value="3462017">Wilson</option>
          
        </select>
        <noscript>
          <br />
          <input type="submit" value="go" />
        </noscript>
      </form>

      <p>or</p>

      <form name="movietimesSearchForm" method="get" action="http://www.inlander.com/spokane/MovieTimes">
        <select name="location" onchange="submit();">
          <option value="">Select a location</option>
          
            <option value="2151829" >Alpine Theatre</option>
          
            <option value="2151827" >AMC River Park Square 20</option>
          
            <option value="2151831" >Bonner Mall Cinemas</option>
          
            <option value="2151823" >Garland Theater</option>
          
            <option value="2153812" >Hayden Discount Cinema</option>
          
            <option value="2151830" >Northtown Mall Stadium 12</option>
          
            <option value="2151835" >Pullman Village Centre Cinemas</option>
          
            <option value="2151832" >Regal Cinemas Riverstone Stadium 14</option>
          
            <option value="2151822" >Regal Spokane Valley Stadium 12</option>
          
            <option value="2151836" >Village Center Airway Heights</option>
          
            <option value="2151833" >Village Centre Cinemas Wandermere</option>
          
        </select>
        <noscript>
           <br />
           <input type="submit" value="go" />
        </noscript>
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="diningSearchForm" method="get" action="http://www.inlander.com/spokane/LocationSearch">
        <input type="hidden" name="locationSection" value="2151205" />

        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            <option value="2151219">American</option>
          
            <option value="2151216">Asian</option>
          
            <option value="2151234">Bakery</option>
          
            <option value="2151235">Barbecue</option>
          
            <option value="2151239">Buffet</option>
          
            <option value="2151232">Burgers</option>
          
            <option value="2151220">Cafe</option>
          
            <option value="2433268">Catering</option>
          
            <option value="2151251">Coffee Shops</option>
          
            <option value="2151228">Diner</option>
          
            <option value="2151237">Donuts</option>
          
            <option value="2151221">Eclectic</option>
          
            <option value="2151222">European</option>
          
            <option value="2151218">Fine Dining</option>
          
            <option value="2412327">Food Trucks</option>
          
            <option value="2151275">General Restaurants</option>
          
            <option value="2151240">Gluten-Free Options</option>
          
            <option value="2151223">Hawaiian</option>
          
            <option value="2151238">Ice cream</option>
          
            <option value="2151229">Italian</option>
          
            <option value="2151230">Mediterranean</option>
          
            <option value="2151231">Mexican/Latin</option>
          
            <option value="2151224">Pizza</option>
          
            <option value="2151225">Pub Grub</option>
          
            <option value="2151226">Sandwiches</option>
          
            <option value="2151227">Seafood</option>
          
            <option value="2604012">Small Plates</option>
          
            <option value="2151236">Steak</option>
          
            <option value="2151233">Sushi</option>
          
            <option value="2151217">Veggie-Friendly</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2151278" >&nbsp;&nbsp;Spokane - Downtown</option>
      
        <option value="2151280" >&nbsp;&nbsp;Spokane - South</option>
      
        <option value="2151279" >&nbsp;&nbsp;Spokane - North</option>
      
        <option value="2151282" >&nbsp;&nbsp;Spokane - West</option>
      
        <option value="2151281" >&nbsp;&nbsp;Spokane Valley</option>
      
        <option value="2151285" >&nbsp;&nbsp;Coeur d'Alene/Post Falls</option>
      
        <option value="2151286" >&nbsp;&nbsp;Sandpoint</option>
      
        <option value="2151291" >&nbsp;&nbsp;Airway Heights</option>
      
        <option value="2151284" >&nbsp;&nbsp;Cheney</option>
      
        <option value="2151287" >&nbsp;&nbsp;Moscow/Pullman</option>
      
        <option value="2151288" >&nbsp;&nbsp;Rural Eastern WA</option>
      
        <option value="2151289" >&nbsp;&nbsp;Rural Idaho</option>
      
        <option value="2151290" >&nbsp;&nbsp;Spokane - East</option>
      
        <option value="2151283" >&nbsp;&nbsp;Liberty Lake</option>
      
        <option value="2151293" >&nbsp;&nbsp;Montana</option>
      
        <option value="2151292" >&nbsp;&nbsp;Canada</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>

    

    <div class="eventSearchBody" style="display: none;">
      <form name="locationSearchForm" method="get" action="http://www.inlander.com/spokane/LocationSearch">
        <select name="locationCategory">
          <option value="">-All Categories-</option>
          
            
              <option value="2151206" >CULTURE & ENTERTAINMENT</option>
            
            <option value="2151277" >&nbsp;&nbsp;Bars</option>
          
            
            <option value="2151244" >&nbsp;&nbsp;Casinos</option>
          
            
            <option value="2151252" >&nbsp;&nbsp;Comedy</option>
          
            
            <option value="2151241" >&nbsp;&nbsp;Dance Club</option>
          
            
            <option value="2151243" >&nbsp;&nbsp;Galleries</option>
          
            
            <option value="2151261" >&nbsp;&nbsp;Games</option>
          
            
            <option value="2151266" >&nbsp;&nbsp;Live Music</option>
          
            
            <option value="2151732" >&nbsp;&nbsp;Movie Theaters</option>
          
            
            <option value="2151248" >&nbsp;&nbsp;Museums</option>
          
            
            <option value="2151246" >&nbsp;&nbsp;Music</option>
          
            
            <option value="2151250" >&nbsp;&nbsp;Theaters</option>
          
            
            <option value="2151253" >&nbsp;&nbsp;Winery/Brewery/Distillery</option>
          
            
              <option value="2151207" >COMMUNITY & PUBLIC SPACES</option>
            
            <option value="2151247" >&nbsp;&nbsp;Community Centers & Event Venues</option>
          
            
            <option value="2151245" >&nbsp;&nbsp;Education & Learning</option>
          
            
            <option value="2151327" >&nbsp;&nbsp;Faith & Spirituality</option>
          
            
            <option value="2151254" >&nbsp;&nbsp;Golf & Country Clubs</option>
          
            
            <option value="2151328" >&nbsp;&nbsp;Health & Wellness</option>
          
            
            <option value="2151242" >&nbsp;&nbsp;Hotel</option>
          
            
            <option value="2151249" >&nbsp;&nbsp;Libraries</option>
          
            
            <option value="2151256" >&nbsp;&nbsp;Parks & Recreation</option>
          
            
            <option value="2151255" >&nbsp;&nbsp;Retail Outlets</option>
          
            
            <option value="2151257" >&nbsp;&nbsp;Sports Venues</option>
          
            
              <option value="2151329" >SHOPPING & SERVICES</option>
            
            <option value="2151334" >&nbsp;&nbsp;Bookstores</option>
          
            
            <option value="2151331" >&nbsp;&nbsp;Financial Institutions</option>
          
            
            <option value="2318351" >&nbsp;&nbsp;Marijuana Business</option>
          
            
            <option value="2151330" >&nbsp;&nbsp;Market/Grocery</option>
          
            
            <option value="2151333" >&nbsp;&nbsp;Pets</option>
          
            
            <option value="2202512" >&nbsp;&nbsp;Public Services</option>
          
            
            <option value="2151332" >&nbsp;&nbsp;Salons</option>
          
        </select>

        <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2151278" >&nbsp;&nbsp;Spokane - Downtown</option>
      
        <option value="2151280" >&nbsp;&nbsp;Spokane - South</option>
      
        <option value="2151279" >&nbsp;&nbsp;Spokane - North</option>
      
        <option value="2151282" >&nbsp;&nbsp;Spokane - West</option>
      
        <option value="2151281" >&nbsp;&nbsp;Spokane Valley</option>
      
        <option value="2151285" >&nbsp;&nbsp;Coeur d'Alene/Post Falls</option>
      
        <option value="2151286" >&nbsp;&nbsp;Sandpoint</option>
      
        <option value="2151291" >&nbsp;&nbsp;Airway Heights</option>
      
        <option value="2151284" >&nbsp;&nbsp;Cheney</option>
      
        <option value="2151287" >&nbsp;&nbsp;Moscow/Pullman</option>
      
        <option value="2151288" >&nbsp;&nbsp;Rural Eastern WA</option>
      
        <option value="2151289" >&nbsp;&nbsp;Rural Idaho</option>
      
        <option value="2151290" >&nbsp;&nbsp;Spokane - East</option>
      
        <option value="2151283" >&nbsp;&nbsp;Liberty Lake</option>
      
        <option value="2151293" >&nbsp;&nbsp;Montana</option>
      
        <option value="2151292" >&nbsp;&nbsp;Canada</option>
      
    
  </select>

        <input type="text" name="keywords" title="Enter keyword" class="text" value="" />
        <input type="submit" value="go" />
      </form>
    </div>
  </div><!-- End of Tabbed Box -->

</div>





<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function() {
  // Main tabs.
  dnSetupTabGroup(
      $$("#EventPicksChooser div.tabs>div"),
      $$("#EventPicksChooser div.eventSearchBody"),
      "tabCurrent", "tabBack", 0
  );

  // Remove default tab behavior.
  $$("#EventPicksChooser div.tabs>div a").each(function (a, index) {
      a.onclick = function() {
        return false;
      };
  });
});
//-->
</script>
<!-- End #EventPicksChooser -->
<div id="Ad300x600x1" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_c_half -->
          <div id="div-gpt-ad-in_blogs_c_half" style="" data-slot="/2606185/in_blogs_c_half" data-output="asynchronous" data-width="300" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_c_half');
                });
            </script>
          </div>
</div><!-- #Ad300x600x1 -->







  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningIsland BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningIsland BlogPost ">
            <h3><span class="headingText">More by Dan Nailen</span></h3>
            <ul class="moduleList">
        
        
        
        <div class="teaserItem">
    
      <li class="l0 archiveImage">
        <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/concert-review-social-distortions-reliable-rock-fills-the-knit">
          <img src="https://media2.fdncms.com/inlander/imager/u/square/3517858/socialdbest.jpg" width="100" height="100" alt="CONCERT REVIEW: Social Distortion&#39;s reliable rock fills the Knit" />
        </a>
      </li>
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/27/concert-review-social-distortions-reliable-rock-fills-the-knit">CONCERT REVIEW: Social Distortion's reliable rock fills the Knit</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Dan Nailen</li>
      
      <li class="l1 longOnly">
        <span class="date">Mar 27, 2017</span>
      </li>
    </ul>
  </li>
  </div>
        
        

      
        
        
        <div class="teaserItem">
    
      <li class="l0 archiveImage">
        <a href="http://www.inlander.com/Bloglander/archives/2017/03/26/this-week-alton-brown-louie-anderson-cda-blues-fest-and-more">
          <img src="https://media1.fdncms.com/inlander/imager/u/square/3495376/ht_alton_brown_mt_141125_16x9_992.jpg" width="100" height="100" alt="THIS WEEK: Alton Brown, Louie Anderson, CdA Blues Fest and more" />
        </a>
      </li>
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.inlander.com/Bloglander/archives/2017/03/26/this-week-alton-brown-louie-anderson-cda-blues-fest-and-more">THIS WEEK: Alton Brown, Louie Anderson, CdA Blues Fest and more</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Dan Nailen</li>
      
      <li class="l1 longOnly">
        <span class="date">Mar 26, 2017</span>
      </li>
    </ul>
  </li>
  </div>
        
        

      
        
        
        <div class="teaserItem">
    
      <li class="l0 archiveImage">
        <a href="http://www.inlander.com/spokane/brickyard-barbershop/BestOf?oid=3454007">
          <img src="https://media1.fdncms.com/inlander/imager/u/square/3454006/shopping3-1-ec25113551b8661c.jpg" width="100" height="100" alt="Best Barbershop" />
        </a>
      </li>
    
  
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://www.inlander.com/spokane/brickyard-barbershop/BestOf?oid=3454007">Best Barbershop</a>
    </h4>
    
      <h5 class="subhead">
        Brickyard Barbershop
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Dan Nailen</li>
      
      <li class="l1 longOnly">
        <span class="date">Mar 23, 2017</span>
      </li>
    </ul>
  </li>
  </div>
        
        

      
             <li class="l0 storyItem more">
               <a href="http://www.inlander.com/spokane/ArticleArchives?author=2349169" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  


<div id="Ad300x250x1" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_d_medRect -->
          <div id="div-gpt-ad-in_blogs_d_medrect" style="" data-slot="/2606185/in_blogs_d_medRect" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_d_medrect');
                });
            </script>
          </div>
</div><!-- #Ad300x250x1 -->






    <div id="TopTopics" class="SpanningIsland BlogPost ">
      <h2>
        
          Top Topics in <span class="topicsIn">Bloglander</span>
        
      </h2>
  
  

  <h4><a href="http://www.inlander.com/Bloglander/archives/news/">News</a> (139)</h4>
  
  <hr />
  

  

  <h4><a href="http://www.inlander.com/Bloglander/archives/music/">Music</a> (27)</h4>
  
  <hr />
  

  

  <h4><a href="http://www.inlander.com/Bloglander/archives/arts-and-culture/">Arts & Culture</a> (16)</h4>
  
  <hr />
  

  

  <h4><a href="http://www.inlander.com/Bloglander/archives/sports/">Sports</a> (15)</h4>
  
  <hr />
  

  

  <h4><a href="http://www.inlander.com/Bloglander/archives/whats-up/">What's Up?</a> (13)</h4>
  
  <hr />
  

      <div class="componentFooter">
        <a class="more" href="http://www.inlander.com/Bloglander/archives/">More</a>
      </div>
    </div>
  
<div id="Ad300x250x2" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_e_medRect -->
          <div id="div-gpt-ad-in_blogs_e_medrect" style="" data-slot="/2606185/in_blogs_e_medRect" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_e_medrect');
                });
            </script>
          </div>
</div><!-- #Ad300x250x2 --><div id="Ad300x100x1" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_f_smallRect -->
          <div id="div-gpt-ad-in_blogs_f_smallrect" style="" data-slot="/2606185/in_blogs_f_smallRect" data-output="asynchronous" data-width="300" data-height="100">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_f_smallrect');
                });
            </script>
          </div>
</div><!-- #Ad300x100x1 --><div id="Ad300x100x2" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_g_smallRect -->
          <div id="div-gpt-ad-in_blogs_g_smallrect" style="" data-slot="/2606185/in_blogs_g_smallRect" data-output="asynchronous" data-width="300" data-height="100">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_g_smallrect');
                });
            </script>
          </div>
</div><!-- #Ad300x100x2 --><div id="Ad300x250x3" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_h_medRect -->
          <div id="div-gpt-ad-in_blogs_h_medrect" style="" data-slot="/2606185/in_blogs_h_medRect" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_h_medrect');
                });
            </script>
          </div>
</div><!-- #Ad300x250x3 --><div id="Ad300x100x3" class="SpanningIsland BlogPost Ad">
  <!-- /2606185/in_blogs_i_smallRect -->
          <div id="div-gpt-ad-in_blogs_i_smallrect" style="" data-slot="/2606185/in_blogs_i_smallRect" data-output="asynchronous" data-width="300" data-height="100">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_blogs_i_smallrect');
                });
            </script>
          </div>
</div><!-- #Ad300x100x3 -->
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      

  
<div id="FooterIconRow" class="GlobalFooter BlogPost ">
 
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiFbook" href="http://www.facebook.com/#!/theInlander?ref=ts" target="_blank">Become a Fan of The Inlander</a> 
          </div>
   </div>
   
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiTwitter" href="https://twitter.com/TheInlander" target="_blank">Get Inlander Twitter Updates</a> 
          </div>
   </div>
   
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiInstagram" href="https://www.instagram.com/theinlander/" target="_self">The Inlander on Instagram</a> 
          </div>
   </div>
   
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiYouTube" href="http://www.youtube.com/user/theinlander" target="_blank">The Inlander on You Tube</a> 
          </div>
   </div>
   
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiDigEd" href="http://issuu.com/theinlander" target="_blank">View Digital Edition</a> 
          </div>
   </div>
   
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiRSS" href="/spokane/syndication" target="_blank">Subscribe to RSS Feeds</a> 
          </div>
   </div>
   
  
    <div class="footerLinkWrapper">
      
      <div class="footerLinkText">
         <a id="fiNewsletters" href="/spokane/NewsletterSignup/Page" target="_blank">Sign Up for Newsletters</a> 
          </div>
   </div>
   
  

 <div class="clear"></div> 
</div>


    <div id="FooterNavigation" class="GlobalFooter BlogPost ">
      <ul>
  
  
  <li class="">
    <a href="http://www.inlander.com/spokane/WhoWeAre/Page" target="_self">
      
        Who We Are
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.inlander.com/spokane/ContactUs/Page?messagetype=advertising" target="_self">
      
        Advertise With Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.inlander.com/spokane/InternshipsFreelancing/Page" target="_self">
      
        Internships & Freelancing
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.inlander.com/spokane/PolicyTerms/Page" target="_self">
      
        Comment Policy & Terms of Use
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.inlander.com/spokane/IssueArchives" target="_self">
      
        Issue Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="submitItem">
    <a href="http://www.inlander.com/spokane/Events/AddEvent" target="_self">
      
        Submit An Event
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.inlander.com/spokane/ReachUs/Page" target="_self">
      
        Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.inlander.com/spokane/ISawYouformSubmission/Page" target="_self">
      
        Submit "I Saw You"
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>
   &copy; 2017
   Inlander 
   <br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div><!-- stats tracking code goes here -->
<!-- GOOGLE ANALYTICS -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-4932074-5']);
  _gaq.push(['_setDomainName', 'inlander.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- END GOOGLE ANALYTICS -->


  <img src="/foundation/images/icons/pixel.gif?oid=3540243" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdBackgroundWallpaper" class="Closer BlogPost Ad">
  <!-- /2606185/in_wallpaper_m_wall -->
          <div id="div-gpt-ad-in_wallpaper_m_wall" style="" data-slot="/2606185/in_wallpaper_m_wall" data-output="asynchronous" data-width="1320" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-in_wallpaper_m_wall');
                });
            </script>
          </div>
</div><!-- End #AdBackgroundWallpaper -->
</div><!-- end gridCloser -->
    </body>
</html>
  


